• Rédaction Tutos'Me

La fonction "SI"




Pour les formules de calcul :

Commencez toujours votre calcul par le signe =, ensuite sans laisser d’espaces, placez un chiffre suivi d’un signe suivi d’un autre chiffre, etc. Ajoutez des ( ) si cela s’avère nécessaire.


APPLICATION DES CONDITIONS AVEC LA FONCTION "SI".

La fonction SI est l’une des plus populaires dans Excel. Elle permet d’établir des comparaisons logiques entre une valeur et le résultat attendu. Dans sa forme la plus simple, la fonction SI a la signification suivante :

  • SI(un élément est vrai, action à effectuer, sinon autre action)

Une instruction SI peut donc avoir deux résultats. Le premier résultat est appliqué si la comparaison est vérifiée, sinon le deuxième résultat est appliqué.

Si vous voulez passer directement à l’utilisation de plusieurs instructions SI, consultez l’article Fonctions SI avancées - Utiliser des formules imbriquées et éviter les pièges.


Exemples simples d’utilisation de la fonction "SI"


  • =SI(C2=”Oui”;1;2)

Dans l’exemple ci-dessus, la cellule D2 indique : SI(C2 = Oui, renvoyer la valeur 1, sinon renvoyer la valeur 2)


  • =SI(C2=1;”Oui”;”Non”)

Dans cet exemple, la formule dans la cellule D2 indique : SI(C2 = 1, renvoyer Oui, sinon renvoyer Non)

Comme vous pouvez le constater, la fonction SI permet d’évaluer du texte et des valeurs. Elle permet également d’évaluer des erreurs. La fonction SI ne se limite pas à la vérification d’une égalité entre deux éléments et au renvoi d’un résultat simple : vous pouvez également utiliser des opérateurs mathématiques et effectuer d’autres calculs en fonction de vos critères. Vous pouvez également imbriquer plusieurs fonctions SI afin d’effectuer plusieurs comparaisons.

Remarque : Si vous comptez utiliser du texte dans des formules, vous devez l’entourer de guillemets (par exemple, “Texte”). La seule exception est l’utilisation des valeurs VRAI ou FAUX qui sont comprises automatiquement par Excel.


Autres exemples d’utilisation de la fonction "SI"

  • =SI(C2>B2;”Dépasse le budget”;”Cadre dans le budget”)

Dans l’exemple ci-dessus, la fonction SI dans la cellule D2 indique SI(C2 est supérieur à B2, renvoyer « Dépasse le budget », sinon renvoyer « Cadre dans le budget »)

  • =SI(C2>B2;C2-B2;0)


Dans l’illustration ci-dessus, au lieu de renvoyer un texte de résultat, nous allons renvoyer un calcul mathématique. La formule dans la cellule E2 a la signification suivante : SI(la valeur Réel est supérieure à la valeur Budget, soustraire le montant de Budget du montant Réel, sinon ne rien renvoyer).

  • =SI(E7=”Oui”;F5*0,0825;0)

Dans cet exemple, la formule dans la cellule F7 indique SI(E7=“Oui”, calculer le montant total dans F5*8,25 %, sinon renvoyer 0 car aucune taxe n’est due)


Utilisation de la fonction "SI" pour vérifier si une cellule est vide


  • =SI(ESTVIDE(D2);"Vide";"Non vide")

Vous devez parfois vérifier si une cellule est vide, généralement pour éviter qu’une formule n’affiche un résultat sans saisie préalable.


En pareil cas, vous pouvez utiliser la fonction SI avec la fonction ESTVIDE :

La formule a la signification suivante : SI(D2 est vide, renvoyer « Vide », sinon renvoyer « Non vide »). Vous pouvez aussi utiliser votre propre formule pour la condition « Non vide ». Dans l’exemple suivant, nous utilisons des guillemets ("") au lieu de la fonction ESTVIDE. Ceux-ci signifient qu’il n’y a « rien ».


  • =SI(D3="";"Vide";"Non vide")


Cette formule a la signification suivante : SI(D3 ne contient aucun élément, renvoyer « Vide », sinon renvoyer « Non vide »). Voici un exemple d’une méthode courante d’utilisation des guillemets ("") pour empêcher le calcul d’une formule si une cellule dépendante est vide :

=SI(D3="";"";VotreFormule())

SI(D3 ne contient aucun élément, ne rien renvoyer, sinon calculer la formule).


Exemple de fonction SI imbriquée

  • =SI(D2=1;”Oui”;SI(D2=2;”Non”;”Peut-être”))

Là où une simple fonction SI présente deux résultats uniquement (True ou False), les fonctions SI imbriquées peuvent comporter de 3 à 64 résultats.


Dans l’illustration ci-dessus, la formule dans la cellule E2 a la signification suivante : SI(D2 est égal à 1, renvoyer « Oui », sinon SI(D2 est égal à 2, renvoyer « Non », sinon renvoyer « Peut-être »)). Notez la présence de deux parenthèses fermantes à la fin de la formule. Elles sont requises pour fermer les deux fonctions SI. Si vous essayez de valider la formule sans ces deux parenthèses, Excel tente de la corriger à votre place.

Tutos'Me - Centre de formation

5 Rue de Copenhague

Roissy en France - CDG

Tel: 01 84 60 68 08

Retrouvez nous sur les réseaux

 

  • CRUNCHBASE TUTOS ME
  • Yelp Social Icône
  • Instagram
  • LinkedIn Social Icône
  • Facebook Classic